Kustom Portal Degredation

Incident Report for Kustom

Resolved

The issues has been resolved and operations resume as normal.
Posted Feb 05, 2026 - 16:57 CET

Investigating

We're currently investigating an issue with Kustom Portal preventing sign in.
Posted Feb 05, 2026 - 16:56 CET
This incident affected: Kustom Portal.