Google Pay Degredation on iOS

Incident Report for Kustom

Resolved

The issue has been resolved and Google Pay is now available on Safari.
Posted Jun 03, 2026 - 14:00 CEST

Monitoring

A temporary fix has been implemented, Google Pay is currently disabled for devices using Safari.
Posted Jun 01, 2026 - 11:25 CEST

Investigating

We are currently investigating an issue affecting Google Pay on iOS devices.

Other payment methods and browsers are unaffected.
Posted May 31, 2026 - 00:20 CEST
This incident affected: Checkout.