Issue with Token Service Charging

Incident Report for Kustom

Resolved

Between 13:04 and 13:07 CEST on June 10, 2026, a credential rotation in the Token Service caused a ~3-minute window where token-based charges were unavailable, returning 404 errors.

Merchants with retry logic in place were able to recover automatically.

The issue has been resolved and charging is operating normally.
Posted Jun 10, 2026 - 13:28 CEST