Signicat is currently experiencing degraded performance

Incident Report for Kustom

Resolved

Our provider, Signicat, has resolved the issue on their end.

The issue impacted merchants between 12:12 and 14:06 CET.
Posted May 11, 2026 - 14:56 CEST

Investigating

Our provider, Signicat, is currently experiencing degraded performance, which may affect identity and age verification services. We are monitoring the situation.

You can find more information on https://status.signicat.com/
Posted May 11, 2026 - 12:50 CEST
This incident affected: Checkout.